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Preface

Overview
Kidproof is an application for kids and parents. It protects your programs while your child is using 
your PC. It is designed by parents and this manual is written from a parent’s point of view. 

Children by nature are very curious. When playing on the computer, they like to press various keys and
click the mouse buttons, and find out what happens. This is fun for a child but is very annoying to 
parents and can be disastrous, especially if  their programs/files are changed or deleted. Our designers, 
a group of parents, had similar experiences with their children. Hence their suggestions were included 
in the creation of this software. Since the release of the beta version of Kidproof, our Parent Group has 
a lot of free time because they did not have to stand over their children’s shoulder to watch they are 
doing. We sincerely hope that Kidproof brings you as much peace of mind and free time as it has 
brought to our Parent Group.

Throughout this manual, the term “Program Manager” is used. Program Manager is the desktop that is 
seen when the Windows operating system is started.

This manual describes how to get started and customize Kidproof. It is broken down into the following
sections:

· Section 1, Introduction describes the benefits of Kidproof and the concept on which the 
application is built.

· Section 2, Getting Started describes the minimum you need to do to start using Kidproof. 

· Section 3, Customizing Kidproof describes the various ways you can customize Kidproof to suit 
your needs.

Requirements
This section describes the hardware and software requirements necessary to run Kidproof.

Hardware
· Processor: 386 or higher
· Memory: 4Mb RAM or more
· Hard Disk: 1.5Mb or more
· Monitor: VGA or higher resolution monitors
· Mouse: Any Windows supported mouse.
· Printer: Optional
Software
· Operating System: Windows 3.1 or 3.11
· Desktop: Program Manager or compatible desktop.

Installation

Installing the Registered version
1. Insert the Setup disk in drive A or B. 
2. From the File Manager, select the Run option from the File menu.
3. Run SETUP.EXE which is in the Kidproof subdirectory, e.g.,

A:\SETUP.EXE
4. This will bring up the Kidproof Setup screen.
5. Setup will ask you to enter your name and organization. You must enter the name of the registered user

and may enter an organization name if applicable.
6. Setup will ask the name of the subdirectory (i.e., path) where you would like to install Kidproof. A 



default value for the subdirectory will be provided. Press the Enter key to accept the default value. 
Overwrite the default value if you prefer another subdirectory.

7. Setup will install Kidproof on the computer.  Setup will add a Program Group and Kidproof icons to 
the Program Manager.

8. Now you are ready to use Kidproof. Please read README.TXT and LICENSE.TXT before you use 
Kidproof.

Installing the Shareware version (Evaluation copy)
1. Create a subdirectory where you would like to install Kidproof. At the DOS prompt enter:
MD C:\KIDPROOF
2. Copy the archived Kidproof file KIDPRO01.EXE into the Kidproof subdirectory e.g., at the DOS 

prompt enter:
COPY KIDPRO01.EXE C:\KIDPROOF
3. Run KIDPRO01.EXE. This executable will self-explode creating a list of files.
4. From the File Manager, select the Run option from the File menu.
5. Run SETUP.EXE which is in the Kidproof subdirectory, e.g.,
C:\KIDPROOF\SETUP.EXE
6. This will bring up the Kidproof Setup screen.
7. Setup will ask the name of the subdirectory (i.e., path) where you would like to install Kidproof. A

default value for the subdirectory will be provided. Press the Enter key to accept the default value. 
Overwrite the default value if you prefer another subdirectory.

8. Setup will install Kidproof on the computer. Setup will add a Program Group and Kidproof icons 
to the Program Manager.

9. Now you are ready to use Kidproof. Please read README.TXT and LICENSE.TXT before you 
use Kidproof.

The Setup program will install the Kidproof software on your system, add a Program Group called 
Kidproof’ and a Program Item called Kidproof’ to the Program Manager.

To de-install Kidproof, take the following steps:
1. Delete the Kidproof installed subdirectory.
2. Delete KIDPROOF.INI file from the Windows directory.



1. Introduction
Kidproof is an application for kids and parents. It allows you, the parent, to protect your files and 
programs when your child is using your PC. Having Kidproof is like having a child’s desktop within 
your desktop. When you launch Kidproof, you are starting a mini-desktop. You add programs to 
Kidproof that you want your child to launch. When your child is launching programs within Kidproof, 
the real desktop, your own, is safe and secure. Your child will not be able to access anything that is 
outside of Kidproof.

Kidproof is very similar to Program Manager. If you know how to use Program Manager then you 
already know a lot about Kidproof. As for your kids, they just have to point and click to launch 
programs.

With Kidproof, you are not required to exit any application just because your child wants to use the 
PC. Kidproof will protect your already running applications Your child will not be able to access any 
applications that are not started from Kidproof.

CAUTION
PLEASE MAKE SURE THAT YOU DO NOT GIVE YOUR KIDS ACCESS TO PROGRAMS THAT 
THEY CAN USE TO ACCESS OTHER (YOUR) PROGRAMS AND FILES. EXAMPLE OF THESE 
TYPE OF PROGRAMS ARE FILE MANAGER, NOTEPAD, ETC. IF THE KIDS ARE GIVEN 
ACCESS TO SUCH PROGRAMS THEN THEY WILL BE ABLE TO ACCESS YOUR PROGRAMS 
AND FILES VIA THESE PROGRAMS. KIDPROOF SHOULD BE CONFIGURED TO CONTAIN 
KID'S PROGRAMS SUCH AS GAMES AND EDUCATIONAL SOFTWARE.

1.1. What is a Program Item?

A program item is an application which is shown as an icon in the application window. The application
can be launched by double-clicking on the icon. The concept of a program item is not new. The icons 
that you see on the Program Manager are also called program items. If you know how to add or change
a program item in Program Manager then you already know how to add or change a program item in 
Kidproof.

Every program item in Program Manager has some information called the Properties of the program 
item. If you have an icon in Program Manager that you wish add to Kidproof so that your child can 
launch that program, then you will be able to add that icon to Kidproof very easily. When you want to 
add a program, that does not have an icon in the Program Manager (which is very rare) to Kidproof, 
you must use the Add Program Item’ screen. Both methods are described later in this manual.

The following is the Kidproof Program Properties screen that is used to view the properties of a 
program item in Kidproof:



The fields in the Kidproof Program Properties screen are explained below: 

Description: 
This field is the description of the program item (e.g., PBrush) as it appears at the bottom of the icon 
displayed in Kidproof.

Command:
This field is the name of the executable file (e.g., C:\WINDOWS\PBRUSH.EXE) which is run when 
the icon displayed in Kidproof is clicked.

Working Directory:
This field is the name of the subdirectory (e.g., C:\WINDOWS) from which the executable reads 
related files.

1.2. What is a .KID file?

All program items that you add to Kidproof are saved to a file with the extension .KID. You will be 
able to create as many .KID files as you like, each with a different set of programs and preferences. If 
you have two or more kids of different ages then they may not be using the same programs and 
therefore not launching the same applications. In such a situation, you can have two or more .KID files
and you will have to open appropriate .KID file each time your child is ready to use your PC.

Later in this manual, you will read how to customize Kidproof by setting your preferences. Remember 
that the preferences are saved in the .KIDID file and therefore are applicable only when the .KID file 
containing them is opened in Kidproof. 

When you install Kidproof, a default .KID file called KIDPRO.KID is created. If you have only one 
kid using the PC or all your kids launch the same applications then this default file will be sufficient 
for you to save all the program items and preferences that you have selected.

1.3. What is Protected Mode?

The Kidproof application runs in two modes. One called the Protected Mode and the other being the 
unprotected mode.

When your kids want to use the PC, you switch Kidproof to Protected Mode. Running Kidproof in 
Protected Mode protects your kids from accessing or deleting your programs. Your kids will only be 
able to run programs that you have given them access to.

When you are setting up the Kidproof application for your kids, you must be in Unprotected Mode. 
This mode allows you to add, change or delete program items, set up your preferences for your kids 
and save the program items and preferences to a file.

When applications are launched in Protected Mode, your kid will not be allowed to do the following:
· Your kids will not be able to minimize any programs that he or she launches. Kids accidentally 

minimize their application and then don’t know the way to get back to the application.
· Your kids will not be able use to hot-keys like Alt-Tab, Alt-Esc, etc. Kids can switch to other 

applications using the hot keys and then don’t know the way back to their application.



· Your kids won’t be able to access any programs that are already running outside of Kidproof, 
which of course, includes the Program Manager. No access to Program Manager means your kids 
will not be able to access or launch programs that you don’t want them to have access to.

2.



Getting Started
Once you have installed Kidproof and launched it from Program Manager, you are ready to add 
programs (i.e., program items) to Kidproof. These programs will be the ones you want your kids to 
launch. In Protected Mode, only programs within Kidproof will be accessible to your kid thus 
protecting your programs. Adding program items to Kidproof is similar to adding program items in the 
Program Manager. 

2.1. Adding program items (icons) to Kidproof

You can add program items to Kidproof in two ways:
1. By selecting Program Manager program items into Kidproof.
2. By adding program items using the Properties screen. 

The first option is much easier to use and is likely to be used by you most often.

2.1.1. Adding Program Manager’s program items

These days almost all software (like games, educational software, etc.) come with Setup or Install 
program. After installing, almost all of them will add an icon to the Program Manager. If you want 
your kid to launch and use any of those program items (icons) in the Kidproof Protected Mode, the 
following steps are the easiest way to add those icons to Kidproof. 

In Kidproof, select the Show Program Manager Icons option from the Program menu. The following 
Program Manager Icons screen will appears:

Use the scroll bar to view all the program items (icons). The program items will be shown in 
alphabetical order. Select the program items you want to add to Kidproof by clicking on the icon. 
Clicking on a selected icon de-selects the icon. You can select more than one icon to add to Kidproof. 

1. Click the Add Programs to Kidproof button to add the program items (icons) to Kidproof. 

The selected icons will appear on the Kidproof main screen. You may now save the program items by 
selecting the Save option from the File menu



Note: 
1. If there are a lot of program items (icons) on the Program Manager desktop, then the Program 

Manager Icons screen will take a little longer than normal to display. Also this is one screen 
which requires quite a bit of virtual memory; to the order of a megabyte.

2. When an executable file associated with a program item resides on an inaccessible CD, removable
disk, or network disk then the icon associated with the program item will not be displayed. Refer 
to the Frequently Faced Problems section in this manual for the resolution on this problem.

2.1.2. Adding program items using the Kidproof Program Properties screen

If your desktop is not using Program Manager, Kidproof may not be able to show icons from your 
desktop in the Show Program Manager Icons screen and in that case you should use the Kidproof 
Program Item screen.

Even if your desktop is using Program Manager, in some situations, you may want to add a program 
item by using the Kidproof Program Properties screen. The screen is very similar to the Program 
Manager’s Program Item screen. To add a program item, select Add from the Program menu. The 
following Kidproof Program Properties screen will appear:

1. In the Description field, enter the description of the program item as you would like to see below 
the program’s icon on the Kidproof main screen.

2. In the Command field, enter the location of the executable file and any necessary command line 
parameters. If you don't know the name and/or location of the executable file, you can click the 
Browse button to search and select the executable file. Refer to the Microsoft Windows 3.1 User 
Manual to learn more about the Browse screen.

3. In the Working Directory field, enter the path where the files required by the executable file are 
located.

4. If you would like to change the icon that will be seen in the Kidproof application window, click 
the Change Icon button to view and select the necessary icon. Refer to the Microsoft Windows 3.1 
User Manual to learn more about the Change Icon screen.

5. Click the OK button to add the program item to Kidproof.

The program item you just added will appear on the Kidproof main window. You may now save the 
program items by selecting the Save option from the File menu

2.2. Adding and changing password necessary to exit from Protected 



Mode.

When you want to exit Kidproof or would like to switch from Protected Mode to unprotected mode, 
you will be required to enter a password. This prevents your kid from being able to Unprotect’ your PC
by switching to Unprotected Mode or by exiting Kidproof.

To set the password which will be required to switch Kidproof into Unprotected Mode, select 
Password from the Preferences menu. The Change Password screen will appear:

1. Enter your old password if there was a previous password for the .KID file. You will be required to
enter it to be able to change it.

2. Enter your new password. 

3. Retype your new password.

4. Click the OK button

You may now save the password by selecting the Save option from the File menu

Note: 
1. Password is saved in the .KID file and therefore will apply only when file containing it is opened.
2. Password can be blank which means that you must enter a blank password to Unprotect’ your PC.
3. The password must be a combination of alphabets, numbers and some special characters like ;’, ~’,

etc. Control characters, e.g., Ctrl-<character>, Alt-<character>, F1, etc., will not be accepted as 
part of the password.

2.3. Saving to a .KID file

When you are done with adding program items, you will have to save your kid’s programs to a file. 
When you start Kidproof again, you can open any of the files you have saved, each could be unique or 
similar, in the programs they contain or the preferences you have set. 

You may also want to save when you make changes to the program items in Kidproof or change your 
preferences. These changes can be saved in the same file (the file that you opened) by using the Save 
option from the File menu or in another file by using Save As menu option from the File menu.

The Save As option from the File menu is very useful when you want to create a file similar to another 
file. If you want to create two files for your two kids then you can first create one file, do a Save As’ to 
save to another file and make changes to that file for your other child.



Note: If you require and create two or more .KID files, we strongly recommend that you create an icon
in the Program Manager for every .KID file you create. Name each icon on the Program Manager in a 
way that  makes it easy to identify it with your child or the type of programs items contained in that 
file (e.g., Kidproof for John’ for JOHN.KID). Refer to the Microsoft Windows 3.1 User Guide on how 
to add a program item to the Program Manager. 

2.4. Running Kidproof in Protected Mode

When you are done adding the programs that you want your kids to launch and use, you are ready to 
give the PC to your kid. However before you let your kids use the PC, you must SWITCH THE 
KIDPROOF APPLICATION TO PROTECTED MODE by selecting the Protected Mode option from 
the Go-To menu.

To prevent your child from exiting Protected Mode, a password is required to switch back to 
unprotected mode. If you do not know the password then you will also be stopped from exiting the 
Kidproof application. Therefore make sure that you know the password before you switch to Protected 
Mode. 

If you have not added any password to the .KID file then there is no password and in such a situation 
you should leave the password as blank and click the OK button on the Password screen to switch to 
Unprotected Mode or exit Kidproof.

2.5. Launching applications in Protected Mode

Once you are in Protected Mode in Kidproof, your kids can safely explore all the programs that you 
have given them access to. They just have to point and click. 

Double-clicking on the icon launches the program. Pressing the Enter key will also launch the selected 
program.

2.6. Switching back to Unprotected Mode

When your want to get back to using your PC or you want to exit the Kidproof application, you will 
have to switch back to Unprotected Mode. 

You can switch back to Unprotected Mode by selecting the Unprotected Mode option from the Go-To 
menu. The password screen will appear:



1. Enter the password or blank if you haven’t set up a password.

2. Click the OK button to Unprotect’ your PC.



3. Customizing Kidproof

3.1. Changing program items

Once you have added program items to Kidproof, there may be a need to change the properties1 of the 
program item. To change the description (name shown below the icons), command (executable file 
name and any command line arguments), working directory and/or the icon, select the program item by
clicking on the icon and then select the Change Properties option from the Program menu. The 
Kidproof Program Properties screen will appear:

Click the OK button once you have made the necessary changes to the properties of the program item. 
Refer to the section Adding program item using the Kidproof Program Properties’ for more 
information on using the above screen.

3.2. Setting up Kidproof to start in Protected Mode

Once you have set up all the programs that your child will launch and use, you may want Kidproof to 
start in Protected Mode (whenever your child’s .KID file is opened or when Kidproof is launched from 
the Program Manager). To indicate this preference, you must select Startup from the Preferences menu.
The Startup screen will appear:

1. Check the Protected Mode box to indicate that you want Kidproof to run in Protected Mode when 
the .KID file is opened.

2. Click the OK button.

To change the startup from Protected Mode to Unprotected Mode, you must select Unprotected Mode 
on the Startup screen.



Note:
The Protected mode preference will not apply when you start Kidproof. It applies when the .KID file 
containing that preferences  is opened. Therefore if you want Kidproof to start in Protected Mode, you 
must configure the Kidproof program item in Program Manager, to have the .KID file as an argument 
on the command line. For more information on this, refer to the section Kidproof to show my kid’s 
desktop at startup’ which is described later in this manual.

3.3. Confirming before going to Protected Mode

If you want Kidproof to confirm before switching to Protected Mode, you can set this preference by 
clicking Confirmation from the Preferences screen. The Confirmation Preferences screen will appear:

1. Check the Go To Protected Mode box to indicate that Kidproof must confirm before switching to 
Protected Mode.

2. Press the OK button.

The following screen will be displayed to confirm the switch to Protected Mode. Click the OK button 
to switch to Protected Mode.

Note: 
The Switch to Protected Mode confirmation preference is by .KID file. 
Confirmation before switching to Protected Mode is not sought when Kidproof is launched from 
Program Manager and when the startup preference is Protected Mode.

3.4. Confirming deletion of program items

If you want Kidproof to confirm before deleting any program items, you can set this preference by 
selecting Confirmation from the Preferences screen. The Confirmation screen will appear:



1. Check the Program Delete box to indicate that Kidproof must confirm before deleting any 
program item.

2. Press the OK button.

A program item can be deleted by pressing the Del key or by selecting Delete option from the Program
menu. The following screen will appear if the Confirm Delete preference is set:

Note: 
The Delete confirmation preference is by .KID file. 

3.5. Creating and saving a .KID file

If you have more than one child using your PC and you want to give each kid different applications to 
use, then you would want to create different .KID files, one for each child, with applications and 
preferences for that kid. To create a new .KID file, do the following:
1. Select the New option from the File menu. If a .KID file is already open and has been changed 

then you will be prompted to save it.
2. Add program items using one of two methods described earlier in this manual.
3. Customize Kidproof by setting your preferences. Preferences like password to Unprotect’’ your 

PC, whether or not you would like the screen saver to come up if the PC is left unattended while 
Kidproof is in Protected Mode, etc.

4. Select Save from the File menu to save the program items and preferences to a file. 

Open the saved file using the Open option from the File menu whenever your child is ready to use your
PC. The following is the Open screen:



You can open any .KID file whenever Kidproof is launched from Program Manager by giving the .KID
file name as the command line argument on the Program Manager’s Program Item Properties screen. 

3.6. Using a different .KID file after starting Kidproof

If there is a situation where one kid is using your PC and now you want to open another .KID file so 
that your other kid can use your PC, you must select the Open option from the File menu. The File 
Open screen will appear:

3.7. Kidproof to show my kid’s desktop when launched from Program 
Manager

Most parents would want to see the program items (icons), that you added and saved to a .KID file, to 
be shown as soon as you launch Kidproof from Program Manager. If you have been saving the 
program items and your preferences to the default file (i.e., KIDPRO.KID), that was provided during 
Setup, then you do not need to perform the following steps. However if you have .KID files other than 
the default file then you can do the following:
1. Select the Kidproof’ Program Group on Program Manager.
2. Select the New option from the File menu on Program Manager. The New Program Object 

screen will be displayed.
3. Select the Program Item option on the New Program Object screen.
4. The following Program Item Properties screen will appear:



Enter the following on the Program Item Properties screen:
· A meaning name in the Description field, e.g., Kidproof for John
· Enter the name and location of the Kidproof application along with the name of the Kid file you 

created, e.g., C:\KIDPROOF\KIDPROOF.EXE C:\KIDPROOF\JOHN.KID
· Click OK to add the program item to the Program Manager.

5. Double-click on the icon Kidproof for John’ to run Kidproof and open John.Kid at startup.

Refer to Windows 3.1 User Guide for more information on how to add a program item (icon) to 
Program Manager.

3.8. Disabling Screen Saver when Kidproof is in Protected Mode

When your kids are using the PC, you may not want the screen saver to start because your screen saver
may be password protected. If you kids are distracted for a while and the screen saver starts then they 
may not be able to get back to their programs because of the password protection. If a situation like 
this happens on your PC, then you can disable the Screen Saver when Kidproof is in Protected Mode. 
To set this preference select Protected Mode from the Preferences menu. The Protected Mode screen 
will appear:

1. Check the Disable Screen Saver application box

2. Press the OK button

Note: 
The disable screen saver application preference is by .KID file. 

3.9. Disabling help when programs are launched in Protected Mode



Sometimes getting help screen is not helpful if it means that your kids cannot get back to what they 
were doing. There are times when your kids could press the help button and would not know the way 
to get back their programs. If this is a problem for you then you can disable help screen by selecting 
Protected Mode from the Preferences menu. The Protected Mode Preferences screen will appear:

1. Check the Disable Help screen box

2. Press the OK button

Notes from the author’s desk: 
It is an extremely difficult task to disable the Windows Help’ screen which the launched applications 
display. Hence, sometimes a not-so-friendly message will be displayed by a launched application 
because Kidproof tries to disable the display of the Help’ screen when the Disable Help screen 
preference is set.

3.10. Maximize Kidproof window in Protected Mode 

If you find your child clicking on the icons outside the Kidproof window (when Kidproof is in 
Protected Mode)and getting frustrated that they don’t work, you can maximize’ the Kidproof screen. 
This will prevent your kids from trying to access what is inaccessible to them. To set this preference 
select Protected Mode from the Preferences menu. The Protected Mode Preferences screen will appear:

1. Check the Maximize Kidproof Screen box.



2. Press the OK button.

Note: 
1. The Maximize Kidproof preference is by .KID file. 
2. This version of Kidproof will allow your kid to restore’ the Kidproof window to its non-

maximized size.

3.11. Option to exit Windows from Kidproof

You may be in a situation where your kids know how to start Windows from DOS and you may have 
added Kidproof in the Startup folder (Program Group). Starting Windows launches Kidproof and now 
you want your kids to exit Windows directly from Kidproof. If you set the Allow Exit Windows from 
Kidproof’ preference then Kidproof provides a menu option called Exit Windows’ (in the File menu), 
which your kids can click. When the Exit Windows’ is clicked, Kidproof initiates exit Windows. 
CAUTION: YOUR KID WILL NOT BE ASKED TO ENTER A PASSWORD. To set this 
preference select Protected Mode from the Preferences menu. The Protected Mode Preferences screen 
will appear:

1. Check the Allow Exit Windows’ from Kidproof box.

2. Press the OK button.

Note: 
The Allow Exit Windows’ from Kidproof preference is by .KID file. 

CAUTION: A lot of thought must be given to setting this preference. When the Exit Windows’ 
menu option is selected, no password is required and returning to DOS will provide your kid 
access to all your files and programs.



Appendix A - Error & Warning Messages
Þ Are you sure you to want to delete item <program item name>?

This message is displayed when you ask to delete a program item. If you click Yes, the program item is
deleted from Kidproof. If you click No, the program item is not deleted.

Þ Cannot open <Kidproof program name>. The file is of the newer version of KIDPROOF.

When Kidproof is launched, it checks whether all pieces (programs) of Kidproof have the same 
version. If it detects that one or more programs are of a newer version then this error message is 
displayed. This mismatch of different version of Kidproof can happen when you attempt to install 
a older version of Kidproof after installing a newer version of Kidproof. If you must install the 
older version, delete all files of the newer version from your PC.

Þ Kidproof is in unprotected mode. Run <program item description>?

This warning message is displayed when you try to launch a program while Kidproof is in Unprotected
Mode. 

Note: All your programs including Program Manager are accessible to your kids when Kidproof is in 
Unprotected Mode. 

Þ Switch to Protected Mode?

This message is displayed when you select Protected Mode option from the Go-To menu. Please 
ensure that you know the password to switch Kidproof back to Unprotected Mode.

Þ The ICON file is blank. You can choose an icon from those available from Kidproof.

Each program item shown on the Kidproof main window is identified by an icon. This icon is read 
from the executable associated with the program item or an icon file that you specified. You can 
specify an icon file by clicking the Change Icon button on the Kidproof Program Properties 
screen. 

This message is displayed when you specify an icon file on the Change Icon screen and the icon file 
does not contain any icons in it.

Executables that you associate with program items contains one or more icon. The icon shown on the 
Kidproof main window is displayed from the executable associated with the program item. If an 
executable that you associated with a program item does not contain any icons in it then this 
message is displayed. When icons are missing in the executable, you can choose icons that come 
with Kidproof.

Þ The password is incorrect.

To switch Kidproof to Unprotected Mode, you have to enter the password. This message is displayed 
when the password that you have entered does not match the password that is saved in the .KID 
file.

Þ The Path <subdirectory name> is invalid.

The name of the file or a DOS subdirectory that you have entered is incorrect or does not exist.

Þ The value for Old Password is not correct.

To change a password, you must enter the old password contained in the .KID file. This message is 



displayed when the password you entered does not match the old password.

Þ The values for New Password and Retype New Password do not match. Try Again.

To set a password, you must enter it twice so that Kidproof can ensure that the password you entered is
correct. This message is displayed when you enter different passwords.

Þ There are no icons for the specified file. You can choose an icon from those available from 
Kidproof

Executables that you associate with program items contain one or more icons. Each program item 
shown on the Kidproof main window is identified by an icon. The icon shown on the Kidproof 
main window is displayed from the executable associated with the program item. If an executable 
associated with a program item does not contain any icons in it then this message is displayed. 
When icons are missing in the executable, you can choose icons that come with Kidproof.

Þ Too many program items in the Program Manager. Unable to display all of them.

When you select Show Program Manager Icon option from the Program menu, Kidproof 
communicates with Program Manager and reads all the program items contained in it. This 
message is displayed when there are more than a certain number of program items in Program 
Manager, and Kidproof for some reason is unable to display all of them. If you must add a 
program item (icon) that is not shown on the Program Manager Icons screen then you should use 
the Add option from the Program menu.

Þ Unable to communicate with the Program Manager.

When you select Show Program Manager Icon option from the Program menu, Kidproof 
communicates with Program Manager and reads all the program items that exist on the Program 
Manager. This message is displayed when Kidproof cannot communicate with Program Manager.

Þ Unable to read program items from the Program Manager.

When you select Show Program Manager Icon option from the Program menu, Kidproof 
communicates with Program Manager and reads all the program items that exist on the Program 
Manager. This message is displayed when Kidproof is able to communicate with Program 
Manager but for some reason is unable to read any program items from Program Manager.

Þ Unable to run <program item description>. Check if the path and the EXE file name are correct.

When you double-click on an icon in the Kidproof  main window, Kidproof attempts to run the 
executable associated with the icon. This message is displayed when the executable is invalid. The
reason for this are many. You could have deleted the executable after you added the program item. 
The executable could have been on a removable disk or on a CD ROM in which case you may not 
have mounted the removable disk or the CD ROM.



Appendix B - How To Register ?
If you have not registered the software yet, but, are completely satisfied with the product, now is the 
time to do it. The benefits of registration are many, but most important ones are:

· You get the most recent version of Kidproof.
· You get the latest copy of the Kidproof User Manual in hard copy.
· You get a license to use the Kidproof software for unlimited time. Your license to use the software 

without registration expires after 30 days.
· You get free support from the time you register for a period of 90 days.
· You will be able to get updates of the software within the first year of your registration for free. 

Shipping and handling may apply.

To register, perform the following steps:
· Select the Registration Form option from the Help menu. The following Registration Form screen 

will appear:

· If you are a California resident, check the CA resident box. If you are residing outside the US, 
check the Non-US residents box.

· Enter your name and address on the screen. Switch on your printer and press the Print button.

· The Registration form will be printed with the name and address you entered. If it is not possible 
to print the registration form, you can email the form to 74131.2630@compuserve.com and send 
check/cash/money order by mail.

· Enter you choice for program disk size and your method of payment. The only thing left is to mail 
the form to us. The address is in the Support section of this document.



Appendix C - Frequently faced problems
Þ I switch Kidproof to Protected Mode and leave my kid to have fun. My kid double-clicks on an 

icon in Kidproof but the program just doesn’t start.

There could be many reasons for this. One possibility is that the application your kid is attempting to 
launch is already running. There are applications that will not run more than one copy of itself, 
e.g., Control Panel. Let just say, for example, that you added Control Panel to Kidproof. Start 
Control Panel from Program Manager. Now launch Kidproof and open the .KID file which has the
Control Panel as one of the launchable programs. Switch Kidproof into Protected mode. Now try 
and launch Control Panel from within Kidproof. An hourglass will appear and disappear and 
nothing will happen. The reason: Only one copy of Control Panel can run at a time. That copy is 
already running because you started it from the Program Manager and therefore the second copy 
from Kidproof will not start.

Þ The right icon does not appear on the Program Manager Icons screen

This is a limitation of Kidproof. The icons shown on the screen are read from the executable associated
with the program item. When an executable file, which resides on a CD, removable disk, or 
network disk, is inaccessible, Kidproof is unable to show the appropriate icon.  The icon that will 
be seen instead is as shown below:
 

The steps to display the right icon are as follows:

1. Identify and select the program items you want to add to Kidproof by confirming the description 
displayed below the 

 icon.

2. Add the program item to Kidproof by clicking on the Add Programs To Kidproof button. The 
program items will appear on the Kidproof main window.

3. Select the 

program item on the Kidproof main window.

4. Select the Change Properties from the Program menu. The Kidproof Program Properties screen 
will appear. Note down on paper the name and path of the executable from the Command Line 
field on the screen.

5. Click the Change Icon button on the screen. The Change Icon screen will appear.

6. Enter the name and path of the executable which you noted down earlier in the File Name field on 
the screen. 

7. Make sure that the executable is accessible, i.e., if the executable is on a CD, put the CD in the 
CD-ROM drive, if the executable is on a removable disk, install the removable disk, and so on.



8. Click the OK button on the Change Icon screen. All icons that are stored in the executable will 
appear in the Current Icon field. Select the icon you want by clicking on the Icon. Press the OK 
button again.

9. The Kidproof Program Properties screen will become active. Click the OK button on the screen. 
The icon selected on the Change Icon screen will be appropriately displayed on the Kidproof main
window.

Þ Every time my child exits an application while Kidproof is in Protected Mode, the PC just hangs.

Kidproof monitors every application that is started by your child when it is in Protected Mode. If 
any application is started once Kidproof is in Protected Mode, it does not allow any other 
application to start nor do it allow any access to your already running applications. Sometimes, 
due to the way these applications are written, Kidproof is unable to monitor them thereby resulting
in locking out the whole PC. This situation is very rare and you need not be alarmed.

When your PC hangs, i.e., when the PC does not accept any keys you press on your keyboard, 
perform the following steps to unlock your PC. These steps will also switch Kidproof into 
Unprotected Mode.

1. Press Ctrl-P, i.e., press the Ctrl key and while is pressed, press the P key and then release both the 
keys.

2. Enter the password that you would have entered to switch Kidproof into Unprotected Mode.

3. Press the F10 key.

If you perform the above steps successfully, the following screen will appear and Kidproof will be 
in Unprotected Mode. You will now be able to access everything on your PC.

Þ I have problem running DOS based games.

Some of the DOS based programs exit Windows (using a special program) they are launched from 
Windows and they restart Windows when you exit the game. Kidproof is a Windows based 
application and it stops working as soon as Windows is exited.

There are two ways to launch these type of games from Kidproof:
1. By adding a program item with the executable being the game itself and not the special 

program.
2. By adding a program item with the executable being a PIF file for the games. For more 

information on PIF, read the Microsoft Windows 3.1 Users Manual.



Appendix D - Sales and Technical Support
If you are having problems using Kidproof, or if you have any questions or comments about Kidproof, 
please write, call, fax, or email us at

Address: Applied Softworks, Inc.
P. O. Box 2508
Santa Clara CA 95055-2508

Voice: 408-554-1010
Fax: 408-554-1010

CompuServe ID: 74131,2630
Internet ID: 74131.2630@compuserve.com

Support Policy

Up to thirty minutes telephone support time (408) 554-1010 during Eastern US  business hours or CIS 
74131,2630 will be provided without charge to registered users during the three months following 
registration. This support is for correcting errors in the program or information contained in the 
manual.

Bugs will be fixed for free for one year following registration, if possible. If not, a full refund will be 
offered.  A written description of the bug, a copy of your program file, and a description of the 
hardware/software environment are essential in notifying us of a bug so we can duplicate the problem.

Support will be provided to non-registered users and users beyond the free support period on a time 
and materials basis.

___________________________
1 The section What is a program item’ explains the various properties of a program item.


